Back to overview
Maintenance
Uploading new version
May 22, 2026 at 6:35am UTC
–
May 22, 2026 at 8:35am UTC
Affected services
Telefonía
Agente de Voz
Resolved
May 22, 2026 at 8:35am UTC
Maintenance ended
Affected services
Created
May 22, 2026 at 6:35am UTC
Phone calls are not currently working during this maintenance
Affected services